20141116171623
Ai theo dõi trang này
Mời quảng cáo

Giáo trình mô phỏng cơ học, Vương Tấn Sĩ

Bài từ Tủ sách Khoa học VLOS

CHƯƠNG TRÌNH MÔ PHỎNG CƠ HỌC

INTERACTIVE PHYSICS 2004 (MSC.Software Corporation)

I. KHÔNG GIAN MÔ PHỎNG TRONG INTERACTIVE PHYSICS.

Khởi động chương trình bằng cách click mouse vào biểu tượng của chương trình mô phỏng. Màn hình xuất hiện không gian mô phỏng (WorkSpace) của InterActive Physics để thực hiện các mô phỏng cơ học.

Các thanh menu, thanh công cụ, hệ trục tọa độ, ô lưới...có thể hiển thị để thực hiện mô phỏng bằng cách click vào menu:

• View-Workspace, sẽ xuất hiện cửa sổ trong đó cho ta tùy chọn như:

1) Toolbar(Thanh công cụ): cung cấp các đối tượng để xây dựng mô hình thí nghiệm và lệnh thực hiện mô phỏng gồm có:

a. Standard - Edit - Run Control - Joint/Split.

b. Body - Points - Joints - Cnstr - Simple (thể hiện thanh Toolbar đơn giản): Body là các đối tượng có dạng tròn, vuông, chữ nhật, đa giác, hình cong dùng để làm mô hình, hoặc có thể kết hợp chúng lại để tạo hình theo yêu cầu của hiện tượng khi đó ta liên kết chúng bằng các công cụ như joints, rigid joint...

2) Navigation: các công cụ hỗ trợ định vị các đối tượng trong WorkSpace khi thiết kế như: - Coordinates: tọa độ.

- Ruler: thước.

- Gride line: ô lưới.

- XY axes: hệ trục tọa độ. 3) Scrolling: thanh trượt

- Tape player control: điều khiển từng bước quá trình thể hiện mô phỏng.

- Scroll bar: các thanh trượt để dịch chuyển màn hình mô phỏng theo chiều ngang và dọc.

4) Coordinates bar: thanh hiển thị toạ độ (x,y), khối lượng m, bán kính r, hướng của 1 đối tượng xác định bởi góc .


II. CÁC ĐỐI TƯỢNG VÀ LỆNH TRONG CHƯƠNG TRÌNH MÔ PHỎNG.

1) Chuẩn bị WorkSpace theo yêu cầu của mô phỏng: xác định hệ trục tọa độ, đơn vị trên trục, tỉ lệ không gian mô phỏng có thể thay đổi kích thước bằng menu lệnh: Zoom in(+), Zoom out(-)

2) Đưa các đối tượng vào WorkSpace: - Click trái mouse vào đối tượng tương ứng trên Toolbar gồm Bodies và Constraints (tuyến tính và quay).

Trong WorkSpace và ở vị trí muốn đặt đối tượng, click, giữ và drag chuột trái cho tới khi đối tượng xuất hiện với kích thước, vị trí, ... mong muốn; có thể Edit các thuộc tính của đối tượng bằng bàn phím trong cửa sổ Properties.

3) Đặt các thuộc tính cho đối tượng: như vị trí, vận tốc, khối lượng, độ cứng của lò xo, hệ số ma sát tĩnh-động (stat fric - kin fric), độ đàn hồi (elastic), ....Có thể chọn 1 số thuộc tính từ “coordinates bar”.

- Click double vào đối tượng để xuất hiện cửa sổ thuộc tính Properties, hoặc từ menu Window chọn Properties(Ctrl + I) và ta nhập các thuộc tính từ bàn phím

4) Tạo giao diện mới ngoài giao diện mặc nhiên của đối tượng.

- Click lên đối tượng, từ menu Window chọn Appearance (Ctrl +J), xuất hiện cửa sổ Appearance.

- Từ cửa sổ Appearance, ta có thể chọn lại tên, màu nền, mẫu nền.; cho ẩn đối tượng, hoặc hiện tên, tâm, điện tích, quỹ đạo tâm khi chuyển động.

- Có thể tạo giao diện mới từ 1 ảnh bitmap: copy ảnh lên clipboard và dán vào WorkSpace. Trong WorkSpace chọn ảnh và đối tượng, từ menu Object click vào lệnh Attach Picture, ảnh bitmap sẽ dán vào đối tượng.

- Đưa 1 đối tượng về phía trước hay về phía sau 1 đối tượng khác từ lệnh Move to Front, Send to Back.

-Ghi chú trong WorkSpace: click vào icon A để gõ text; vào menu Object để chọn Font(font, fontstyle, size).


5) Kết nối các đối tượng trong Toolbar: để tạo mô hình từ các công cụ Slot Joints Tools( điểm nối với khe) và Point - Slot Tools (điểm nối - khe trượt) sau đây:

Ta có thể kểt hợp giữa Point và Slot để tạo thành Slot Joint:

6)Tách rời (Split) hay nối lại (Join) các đối tượng đã liên kết. Click trái mouse lên đối tượng cần tách rời hay nối lại, sau đó click mouse vào menu Split hay menu Join.

7) Menu mũi tên: click mouse vào menu này để thoát khỏi đối tượng cũ trước khi chọn hay tương tác với đối tượng mới. Muốn xóa đối tượng, ta click lên nó và bấm nút Delete.

8) Soạn thảo văn bản trong WorkSpace: click mouse vào menu A và kết hợp với Font. - Menu mũi tên cong (Rotate) để xoay hướng đối tượng quanh tâm của nó.

Có thể chọn menu Rotate bằng phím ‘R’, menu Arrow bằng phím ‘Spacebar’.

- Menu + (Zoom in): tăng độ phóng đại WorkSpace lên 2 lần, ấn Shift sẽ chuyển tác động về Zoom out.

- Menu - (Zoom out): giảm độ phóng đại WorkSpace xuống 1/2 lần, ấn Shift sẽ chuyển tác động về Zoom in.

9) Thực hiện, dừng, và đặt lại mô phỏng: bấm lần lượt Run, Stop và Reset.

10) Lưu trữ, cắt, dán, in file mô phỏng.

11) Tạo các trường trong mô phỏng:

Như Trường lực (Force Field), Trọng lực (Gravity), Lực cản không khí (Air Resistance), Lực tĩnh điện (Electrostatic) từ menu World. Từ menu này ta có thể chọn lệnh xóa Track(Ctr + E) để không lưu lại vết của đối tượng trước khi thực hiện lại mô phỏng.

Cửa sổ chọn lực cản không khí

Cửa sổ chọn trường lực


Cửa sổ chọn trường tĩnh điện

12) Đo giá trị của các đại lượng Vật lý trong mô phỏng.

Trước khi chạy mô phỏng bằng lệnh Run, click mouse vào đối tượng muốn đo giá trị các đại lượng. Từ menu Measures, click mouse vào các menu đại lượng Vật lý như: - Time: thời gian.

- Position: Vị trí.

- Velocity: Vận tốc.

- Acceleration: Gia tốc.

- P-V-A: Vị trí - Vận tốc - Gia tốc.

- Center of Mass Position: Vị trí tâm khối.

- Center of Mass Velocity: Vận tốc tâm khối.

- Center of Mass Acceleration: Gia tốc tâm khối.

- Momentum: Động lượng.

- Angular momentum: Động lượng góc.

- Total force: Lực tổng hợp.

- Total Torge: Tổng momen quay.

- Gravity force: Trọng lực.

- Electrostatic force: Lực tĩnh điện.

- Air force: Lực cản không khí.

- Force Field: Trường lực.

- Kinetic Energy: Động năng.

- Gravity Potential: Thế năng.

Các đại lượng đo được này hiển thị bằng Meter có thể có các thành phần đại luợng dài theo trục X, trục Y và theo góc dưới 3 dạng:

a) Gíá trị bằng số (digital)

b) Đồ thị (graph)

c) Thanh mức (bar)

Muốn chuyển đổi giữa 3 dạng này ta click vào mũi tên trong Meter. Có thể biểu diễn các đại lượng dưới dạng Vector, nó cho biết độ lớn và hướng của các đại lượng như vận tốc, gia tốc, lực. Khi hiển thị Meter dưới dạng graph, ta phải kết hợp với cửa sổ Properties (Ctrl+I) và cửa sổ Apperance (Ctrl+J) thì đồ thị nhận được mới rõ nét.

13) Hiển thị 1 đại lượng trong mô phỏng dưới dạng Vector theo thứ tự:

- Chọn đối tượng mô phỏng.

- Từ menu Define, chọn Vector.

- Chọn Vector: Vận tốc, gia tốc, lực...

Để biểu diễn dưới dạng Vector, và các thuộc tính của nó như: độ dài, màu ..., ta chọn menu Define - Vector Display & Vector Lengths.

14) Tạo các nút lệnh điều khiển mô phỏng trong WorkSpace.

a) Từ menu Define, chọn New button.

b) Tạo nút Run, Run/Stop, Reset, ... : Từ hộp thoại New Menu Button, ta chọn menu tương ứng và tạo thuộc tính cho các nút này từ Window-Appearance.

c) Click vào nút Run, Run/Stop, Reset ... để thực hiện các lệnh trong mô phỏng.

15) Tạo các nút ‘Control’ trong WorkSpace để chọn vị trí, vận tốc, khối lượng, động lượng,...cho các đối tượng mô phỏng.

a) Click chọn đối tượng.

b) Từ menu Define - New Control, ta có thể chọn điều khiển các đại lượng của đối tượng như vị trí ban đầu, vận tốc-vận tốc góc ban đầu, khối lượng, động lượng ...

c) Click mouse vào Control mới chọn, ví dụ như điều khiển vận tốc Vx của bi, từ menu Window-Properties/Appearance ta có thể chọn các thuộc tính của nút Control như: cách tác động của nút, khoảng giá trị thay đổi từ min đến max.

16) Chuyển từ màn hình edit sang màn hình mô phỏng: loại bỏ 1 số Toolbar để tăng không gian mô phỏng ta dùng lệnh Edit - Player mode. Muốn chuyển từ màn hình mô phỏng về màn hình Edit ta dùng lệnh Edit - Edit mode..

17) Định thời gian Pause, Stop, Reset, Loop, Delete quá trình mô phỏng: từ menu World-Pause Control với điều kiện t>...s.

III. MÔ PHỎNG HIỆN TƯỢNG CƠ HỌC.

1) Các bước thực hiện 1 mô phỏng

- Chọn New từ menu File.

- Chọn các Bodies và Constraints bằng cách click mouse lên các icon tương ứng trong Toolbar (hoặc từ 1 chương trình vẽ khác). Tại vị trí đặt đối tượng trong WorkSpace, click giữ mouse và drag để thay đổi kích thước của đối tượng cho thích hợp.

- Click double lên đối tượng để mở cửa sổ Properties và edit các thuộc tính ban đầu như vận tốc, hệ số ma sát, độ đàn hồi...hay hiệu chỉnh lại vị trí từ bàn phím.

- Từ menu Measure, chọn các đại lượng Vật lý muốn đo thể hiện bằng Meter dưới dạng số (digital), đồ thị (graph) hay thanh mức (bar).

- Click vào menu Run để chạy mô phỏng.

- Click vào menu Stop để dừng mô phỏng.

- Lưu mô phỏng bằng lệnh Save trong menu File.

- Chọn Close trong menu File để kết thúc mô phỏng.

2) Các thí nghiệm mô phỏng a) Dao động con lắc.

b) Dao dộng của hệ điện tích

c) Chuyển động.

d) Va chạm.

  • Va chạm 3 & 4 bi.

e) Chuyển động của hạt mang điện trong từ trường.

f) Dao động liên kết

g) Va chạm đàn hồi.

h) Chuyển động của các vật trong trọng trường.

i) Chuyển động trong các hệ qui chiếu.

 
Gõ tiếng Việt có dấu:
(Hỗ trợ định dạng wikitext)
Công cụ cá nhân